Bug 307

Summary: Strange layout behavior with nails and .xta files
Product: UPPAAL Reporter: Niels Braspenning <n.c.w.m.braspenning>
Component: GUIAssignee: Gerd Behrmann <behrmann>
Status: RESOLVED FIXED    
Severity: normal    
Priority: P1    
Version: 3.6 Beta 1   
Hardware: All   
OS: All   
Architecture:

Description Niels Braspenning 2006-03-29 16:13:25 CEST
I get strange layout behavior with nails, when I do the following:

- create TA with two locations and two transitions, both from initial to end location
- separate these transitions with nails, e.g. pull one transition up and the other one down
- save this TA in a .xta file (and accompanying .ugi file)
- reopen this .xta file

Now I see that the two nails (that were connected to both transitions to separate them) are now connected to only one of the two transitions, i.e. one transition is now straight with no nails and the other one makes an S curve through both nails.
Comment 1 Gerd Behrmann 2006-03-29 16:36:36 CEST
Confirmed. Seems to be a problem in the serialization to XTA.
Comment 2 Gerd Behrmann 2006-04-10 18:03:42 CEST
Fixed on the trunk from rev. 1710.