Bug 100 - Cannot run with JRE 1.5
Summary: Cannot run with JRE 1.5
Status: CLOSED FIXED
Alias: None
Product: UPPAAL
Classification: Unclassified
Component: GUI (show other bugs)
Version: 3.4.5
Hardware: All All
: P2 normal
Assignee: Gerd Behrmann
URL:
Depends on: 80
Blocks:
  Show dependency treegraph
 
Reported: 2004-04-27 12:08 CEST by Gerd Behrmann
Modified: 2005-02-18 11:07 CET (History)
0 users

See Also:
Architecture:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Gerd Behrmann 2004-04-27 12:08:49 CEST
When using Java JRE 1.5 beta 1, running the Uppaal GUI produces an "invalid jar
file" error.
Comment 1 Gerd Behrmann 2004-04-27 12:09:44 CEST
This is caused by Condensity (the scrambler). When not using the scrambler
Uppaal starts fine, but then runs into another problem when trying to connect to
the verification backend. Further investigation is needed.
Comment 2 Gerd Behrmann 2004-05-04 10:47:47 CEST
There is a problem with Xerces 2.5.x and JRE 1.5 beta 1. Due to bug 80, we have
not used a newer version of Xerces.

I have now fixed bug 80. Hence we can upgrade to the newest version of Xerces
and this should fix some of the problems with JRE 1.5 beta 1.

The scrambler problem is a bit tricky: Condensity is now officially dead. I'm
currently looking for a new scrambler.
Comment 3 Gerd Behrmann 2004-05-13 14:03:53 CEST
Due to the changed default theme in JRE 1.5 on Linux, I have changed the toolbar
to have a flat look. This also looks better on Windows.
Comment 4 Gerd Behrmann 2004-06-04 22:22:01 CEST
I have extended the build script to also support proguard to obfuscate the 
files. This should fix compatibility problem with JRE 1.5. 
Comment 5 Gerd Behrmann 2004-06-10 13:15:26 CEST
Turns out that condensity works fine with JRE 1.5 beta 2. Hence we have the
option to continue using condensity.
Comment 6 Gerd Behrmann 2004-06-29 09:45:43 CEST
There are more problems with uppaal and JRE 1.5: When model checking with
diagnostic traces turned on, the GUI dies in the dialog asking whether the trace
shoulded by loaded into the Simulator. It is not possible to press the Yes or No
button in the dialog.
Comment 7 Gerd Behrmann 2004-08-26 13:38:35 CEST
A fix for the remaining issue has been checked into CVS. The problem was that we
disabled the SystemInspector during verification. In Java 5 this turns out also
to disable events to the "Load trace" dialog.