Bug 154 - Problems with text format: On special chars GUI produces empty error message or crashes server
Summary: Problems with text format: On special chars GUI produces empty error message ...
Status: RESOLVED FIXED
Alias: None
Product: UPPAAL
Classification: Unclassified
Component: GUI (show other bugs)
Version: 3.5.6
Hardware: PC Windows 2000
: P1 minor
Assignee: Gerd Behrmann
URL:
Depends on:
Blocks:
 
Reported: 2005-05-18 15:13 CEST by René Gøttler
Modified: 2006-03-16 18:57 CET (History)
0 users

See Also:
Architecture:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description René Gøttler 2005-05-18 15:13:35 CEST
Loading a model containing special characters like Ç makes the GUI open an 
empty error message if the model was produced using the GUI - if instead an xml 
editor is used to insert a special character in a model, then instead a 
protocol error kills the server upon load.

Libutap reports that it is a problem with the text format, e.g.,

model.xml:6: parser error : Input is not proper UTF-8, indicate encoding !
Bytes: 0xC7 0x73 0x66 0x64
 * aÇsfdlkj
    ^
Comment 1 Mads Schaarup Andersen 2005-05-19 13:23:19 CEST
Bug reproduced.
Should this bug maybe be split into a bug both in the GUI and in the server?

Reassigning
Comment 2 Gerd Behrmann 2005-06-03 13:59:38 CEST
The problem seems to be isolated to Windows.
Comment 3 Gerd Behrmann 2005-06-03 14:01:57 CEST
3.4.10 does not seem to suffer from the problem.
Comment 4 Gerd Behrmann 2005-11-06 17:42:24 CET
Must be resolved before 3.6 final. Increasing priority.
Comment 5 Gerd Behrmann 2006-03-16 18:57:30 CET
Fixed on the trunk from rev. 1658.