Bug 157 - Wrong location in syntax errors.
Summary: Wrong location in syntax errors.
Status: RESOLVED FIXED
Alias: None
Product: UPPAAL
Classification: Unclassified
Component: libutap (show other bugs)
Version: 3.5.6
Hardware: All All
: P2 normal
Assignee: Gerd Behrmann
URL:
: 156 (view as bug list)
Depends on:
Blocks:
 
Reported: 2005-06-02 17:26 CEST by Gerd Behrmann
Modified: 2005-06-03 13:05 CEST (History)
1 user (show)

See Also:
Architecture:


Attachments
Test case. (8.28 KB, application/octet-stream)
2005-06-02 17:27 CEST, Gerd Behrmann
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Gerd Behrmann 2005-06-02 17:26:21 CEST
When the attached model is loaded into the GUI, a NullPointerException is thrown.
Comment 1 Gerd Behrmann 2005-06-02 17:27:07 CEST
Created attachment 37 [details]
Test case.
Comment 2 Gerd Behrmann 2005-06-02 18:12:52 CEST
Turns out to be a bug in libutap where the proper context is not maintained.
Comment 3 Gerd Behrmann 2005-06-03 12:56:46 CEST
Updated summary.
Comment 4 Gerd Behrmann 2005-06-03 13:02:38 CEST
A fix for 3.5 has been checked into. The bug does not seem to be present in 3.4.10.
Comment 5 Gerd Behrmann 2005-06-03 13:05:38 CEST
*** Bug 156 has been marked as a duplicate of this bug. ***