Bug 163 - Syntax error in a struct crashes syntax checker
Summary: Syntax error in a struct crashes syntax checker
Status: RESOLVED FIXED
Alias: None
Product: UPPAAL
Classification: Unclassified
Component: libutap (show other bugs)
Version: 3.5.7
Hardware: All All
: P3 normal
Assignee: Gerd Behrmann
URL:
Depends on:
Blocks:
 
Reported: 2005-06-23 13:34 CEST by René Gøttler
Modified: 2005-07-12 14:49 CEST (History)
0 users

See Also:
Architecture:


Attachments
An example model containing a broken struct (826 bytes, text/html)
2005-07-08 09:54 CEST, René Gøttler
Details

Note You need to log in before you can comment on or make changes to this bug.
Description René Gøttler 2005-06-23 13:34:41 CEST
A missing semi-colon at the end of the last struct member, crashes the server 
for Windows with a "memory could not be written" error message.

An example struct:

struct {
  int x;
  int y
} p;
Comment 1 Gerd Behrmann 2005-07-04 15:14:26 CEST
I am unable to reproduce this problem. Please attach a test case.
Comment 2 René Gøttler 2005-07-08 09:54:01 CEST
Created attachment 47 [details]
An example model containing a broken struct

Here is a small model that exposes the bug I described - at least it does so on
my machine.
Comment 3 Gerd Behrmann 2005-07-08 10:14:01 CEST
The existens of the function test() is the test case seems significant for triggering the crash. 

Exact behaviour depends on the platform: On windows the server crashes immediately, whereas on Mac it 
only crashes after pressing the syntax check key (F7) several times.
Comment 4 Gerd Behrmann 2005-07-12 14:49:00 CEST
A fix has been committed to CVS.