Bug 177 - verifyta segfaults on use of -T option
Summary: verifyta segfaults on use of -T option
Status: RESOLVED FIXED
Alias: None
Product: UPPAAL
Classification: Unclassified
Component: Engine (show other bugs)
Version: 3.5.8
Hardware: All All
: P2 major
Assignee: Gerd Behrmann
URL:
Depends on:
Blocks:
 
Reported: 2005-07-14 17:26 CEST by Ferdy Hanssen
Modified: 2005-08-05 20:55 CEST (History)
0 users

See Also:
Architecture:


Attachments
Model (4.29 KB, text/xml)
2005-07-14 17:26 CEST, Ferdy Hanssen
Details
Query file (158 bytes, text/plain)
2005-07-14 17:27 CEST, Ferdy Hanssen
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Ferdy Hanssen 2005-07-14 17:26:22 CEST
In some cases verifyta 3.5.8 (not in bugzilla) segfaults on the use of -T.

I cannot pinpoint it exactly, but the attached model and query file show it when
run with 'verifyta -N -T'.  When not using the -T option the segfault does not
occur.
Comment 1 Ferdy Hanssen 2005-07-14 17:26:51 CEST
Created attachment 50 [details]
Model
Comment 2 Ferdy Hanssen 2005-07-14 17:27:16 CEST
Created attachment 51 [details]
Query file
Comment 3 Ferdy Hanssen 2005-07-14 18:14:23 CEST
verifyta 3.5.7 does not exhibit this problem
Comment 4 Gerd Behrmann 2005-07-17 18:18:24 CEST
Confirmed. This is most likely caused by the fix for bug 170.
Comment 5 Gerd Behrmann 2005-08-05 18:49:32 CEST
The problem was not directly in the fix of bug 170, but rather that the fix of bug 170 made that part of 
the code non-reentrant.

For 3.5 I have checked in a fix that removes the requirement that this particular code fragment must be 
reentrant. 

3.4.11 might suffer from the same problem, so I do not close the bug.
Comment 6 Gerd Behrmann 2005-08-05 20:51:48 CEST
3.4.11 is affected by the same problem. Increasing the severity of the bug.

A fix has been checked into CVS.
Comment 7 Gerd Behrmann 2005-08-05 20:55:31 CEST
Correction: 3.4.11 did not yet contain the fix for bug 170. Hence a version of 3.4 containing this problem 
was never released. Reducing severity again :-)