Bug 181 - Random simulation destroys the trace anyway
Summary: Random simulation destroys the trace anyway
Status: RESOLVED FIXED
Alias: None
Product: UPPAAL
Classification: Unclassified
Component: GUI (show other bugs)
Version: 3.5.8
Hardware: All All
: P2 normal
Assignee: Mads Schaarup Andersen
URL:
Depends on:
Blocks:
 
Reported: 2005-08-05 13:16 CEST by Saulius Pusinskas
Modified: 2005-08-10 15:14 CEST (History)
1 user (show)

See Also:
Architecture:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Saulius Pusinskas 2005-08-05 13:16:32 CEST
Sequence of actions is needed to trigger the bug:
1. Load the model and produce some trace using UppAal verifier.
2. Return to the simulation window and select any, but not last, step in the trace
3. Press the button "Random".
Dialog box appears "Warning: this will destroy a part of the trace! Continue?"


After pressing "No", same dialog box keeps opening again.
Comment 1 Gerd Behrmann 2005-08-05 20:28:21 CEST
Confirmed.
Comment 2 Gerd Behrmann 2005-08-06 09:37:04 CEST
Mads, this might be another easy bug for you to fix.

The problem is that the random simulation is run by an extra thread. This thread doesn't notice that you 
answer no to the overwrite question, thus it continous to periodically select a transition.
Comment 3 Mads Schaarup Andersen 2005-08-10 15:14:17 CEST
A fix has been checked into cvs.