Bug 207 - Out of range assignment in struct
Summary: Out of range assignment in struct
Status: RESOLVED FIXED
Alias: None
Product: UPPAAL
Classification: Unclassified
Component: Engine (show other bugs)
Version: unspecified
Hardware: All All
: P2 normal
Assignee: Gerd Behrmann
URL:
: 208 (view as bug list)
Depends on:
Blocks:
 
Reported: 2005-10-06 13:42 CEST by Gerd Behrmann
Modified: 2005-10-06 17:55 CEST (History)
0 users

See Also:
Architecture:


Attachments
Test case in XTA format (421 bytes, application/octet-stream)
2005-10-06 13:42 CEST, Gerd Behrmann
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Gerd Behrmann 2005-10-06 13:42:18 CEST
In the attached model, the engine reports an out of range assignment. But this should not happen.

It works in 3.5.9 but not in the current CVS release.
Comment 1 Gerd Behrmann 2005-10-06 13:42:44 CEST
Created attachment 65 [details]
Test case in XTA format
Comment 2 Gerd Behrmann 2005-10-06 17:33:27 CEST
*** Bug 208 has been marked as a duplicate of this bug. ***
Comment 3 Gerd Behrmann 2005-10-06 17:55:01 CEST
A fix has been checked in.