Bug 284 - Global function names overlapping with local variable names
Summary: Global function names overlapping with local variable names
Status: RESOLVED FIXED
Alias: None
Product: UPPAAL
Classification: Unclassified
Component: libutap (show other bugs)
Version: unspecified
Hardware: All All
: P1 normal
Assignee: Gerd Behrmann
URL:
Depends on:
Blocks:
 
Reported: 2006-03-02 15:05 CET by Saulius Pusinskas
Modified: 2006-03-03 11:10 CET (History)
0 users

See Also:
Architecture:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Saulius Pusinskas 2006-03-02 15:05:06 CET
Having a function in global declarations, say

   void f(int number) { ... }

and the local variable in some template under same name, say

   int f;

the Update statement on any of template's transitions, like

   f(f)

has no effect since function's name is masked with local variable's name.



It is also possible to define a (local) variable like

   int v;

and include expression on the update of some of the template's transitions:

   v(v)

Uppaal will not complain in such case either, while it should since no function with name "v" is declared.
Comment 1 Alexandre David 2006-03-02 15:16:36 CET
Talked to Gerd. This is a regression in 3.6.alpha5.pre2 since pre1. Re-assigning to proper owner.
Comment 2 Gerd Behrmann 2006-03-03 09:35:13 CET
Correction: This is a current since alpha 4. Alpha 5 pre1 has the same problem.
Comment 3 Gerd Behrmann 2006-03-03 11:10:48 CET
Fixed as of rev. 1593.