Bug 291 - ArrayIndexOutOfBounds exception when updating simulator
Summary: ArrayIndexOutOfBounds exception when updating simulator
Status: RESOLVED FIXED
Alias: None
Product: UPPAAL
Classification: Unclassified
Component: GUI (show other bugs)
Version: 3.6 Alpha 5
Hardware: All All
: P1 major
Assignee: Robert Olesen
URL:
Depends on:
Blocks:
 
Reported: 2006-03-10 11:48 CET by Marius Mikučionis
Modified: 2006-03-10 16:09 CET (History)
0 users

See Also:
Architecture:


Attachments
model to reproduce an exception (11.26 KB, application/xml)
2006-03-10 11:49 CET, Marius Mikučionis
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Marius Mikučionis 2006-03-10 11:48:14 CET
I was playing with Uppaal 3.6 beta1 pre1 rev. 1625

to reproduce it try:
1) open testsuite.xml (attached)
2) go to simulator
3) pick and fire transition (e.g. one2many: ...)
4) go back to editor, system declarations
5) add env2 process
6) switch to simulator, say yes to update it
7) Caught unexpected ... message box appears.
and the terminal is full of traces of course...
Comment 1 Marius Mikučionis 2006-03-10 11:49:17 CET
Created attachment 93 [details]
model to reproduce an exception
Comment 2 Gerd Behrmann 2006-03-10 13:04:31 CET
Alpha 5 has the same problem. May be caused by the fix for bug 96.
Comment 3 Gerd Behrmann 2006-03-10 13:17:30 CET
This was introduced in rev. 1569. Robert, that is you change. Can you please take a look at this asap. Thanks.
Comment 4 Robert Olesen 2006-03-10 14:28:06 CET
(In reply to comment #3)
> This was introduced in rev. 1569. Robert, that is you change. Can you please
> take a look at this asap. Thanks.
> 

I have found the errors. I'll read the code through an extra time and then commit as soon as I get home today.
Comment 5 Gerd Behrmann 2006-03-10 14:34:41 CET
(In reply to comment #4)
> I have found the errors. I'll read the code through an extra time and then
> commit as soon as I get home today.

That was fast, thanks! How severe is it? That is, how likely is it that our users will run into this problem?
Comment 6 Robert Olesen 2006-03-10 16:09:00 CET
The zoom level of processes and their visibility is remembered in some arrays in the simulator each time the system is reuploaded. I forgot to pay attention to theese arrays changing their size when the system definition is expanded (or reduced for that matter) with additional processes.

I have fixed the bug and checked it into SVN as revision 1633.