Bug 294 - Uppaal seg fault on ? : expression
Summary: Uppaal seg fault on ? : expression
Status: RESOLVED FIXED
Alias: None
Product: UPPAAL
Classification: Unclassified
Component: Engine (show other bugs)
Version: 3.6 Alpha 5
Hardware: All All
: P1 major
Assignee: Gerd Behrmann
URL:
Depends on:
Blocks:
 
Reported: 2006-03-15 12:54 CET by Anders Rune Jensen
Modified: 2006-03-15 20:42 CET (History)
0 users

See Also:
Architecture:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Anders Rune Jensen 2006-03-15 12:54:24 CET
The bug can be reproduced using the following function:

int min(int lhs, int rhs)
{
        return (lhs < rhs) ? lhs : rhs;
}

The problem crashes verifyta (in gdb it looks like an infinite loop) and in the GUI one looses connection to the server.
Comment 1 Gerd Behrmann 2006-03-15 14:36:41 CET
Interesting. I will take a look.
Comment 2 Gerd Behrmann 2006-03-15 20:42:09 CET
Fixed on the trunk from rev. 1650.