Bug 340 - Startup failure with Java 1.6 and no network connection
Summary: Startup failure with Java 1.6 and no network connection
Status: RESOLVED FIXED
Alias: None
Product: UPPAAL
Classification: Unclassified
Component: GUI (show other bugs)
Version: 4.0.1
Hardware: All All
: P2 normal
Assignee: Gerd Behrmann
URL:
Depends on:
Blocks:
 
Reported: 2006-07-19 12:56 CEST by Gerd Behrmann
Modified: 2006-09-30 13:30 CEST (History)
0 users

See Also:
Architecture:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Gerd Behrmann 2006-07-19 12:56:21 CEST
When using Java 1.6 beta 2, the GUI apparently tries to download the DTD from the UPPAAL web site. This fails if machine has no network connection.

This is mostly likely caused by Java 1.6 including a stax compatible XML parser, which replaces the one we ship with UPPAAL. Apparently, Sun's parser tries to validate the XML documents.
Comment 1 Gerd Behrmann 2006-07-31 19:05:14 CEST
Fixed on the trunk from rev. 2478.
Comment 2 Gerd Behrmann 2006-07-31 19:22:30 CEST
Fixed on the 4.0 branch from rev. 2479.
Comment 3 Gerd Behrmann 2006-09-30 13:30:38 CEST
The old DTD from UPPAAL 3.4 has been added to the 4.0 branch and the trunk in rev. 2714 and 2715, respectivly. This should solve slow loading of old models when using JDK 1.6.