Bug 371 - java exception upon openning/saving customized Uppaal models
Summary: java exception upon openning/saving customized Uppaal models
Status: RESOLVED FIXED
Alias: None
Product: UPPAAL
Classification: Unclassified
Component: GUI (show other bugs)
Version: 4.0.3
Hardware: PC Linux
: P1 enhancement
Assignee: Gerd Behrmann
URL:
Depends on:
Blocks:
 
Reported: 2006-11-16 16:55 CET by Marius Mikučionis
Modified: 2006-12-27 21:46 CET (History)
0 users

See Also:
Architecture:


Attachments
Uppaal-TK created model specification (777 bytes, text/xml)
2006-11-16 16:56 CET, Marius Mikučionis
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Marius Mikučionis 2006-11-16 16:55:37 CET
I have an experimental Uppaal branch for TK project (call it uppaal-tk).
The uppaal-tk created documents have two extra labels on edges (and perhaps smth more).
The problem is that original Uppaal chokes upon such documents when opening and trying to save later by throwing the following exceptions:
java.lang.NullPointerException
        at com.uppaal.model.core2.Property.getPrototypeFromParent(Property.java:72)
        at com.uppaal.model.core2.Element.importInto(Element.java:340)
        at com.uppaal.model.core2.Element.setPrototype(Element.java:353)
        at com.uppaal.model.core2.Element.importInto(Element.java:340)
        at com.uppaal.model.core2.Element.setPrototype(Element.java:353)
        at com.uppaal.model.core2.Node.setPrototype(Node.java:179)
        at com.uppaal.model.core2.Element.importInto(Element.java:340)
        at com.uppaal.model.core2.Node.setPrototype(Node.java:182)
        at com.uppaal.model.core2.Element.importInto(Element.java:340)
        at com.uppaal.model.core2.Node.setPrototype(Node.java:182)
        at com.uppaal.gui.SystemInspector.a(Unknown Source)
        at com.uppaal.gui.SystemInspector.f(Unknown Source)
        at com.uppaal.gui.SystemInspector.a(Unknown Source)
        at com.uppaal.gui.Main.b(Unknown Source)
        at com.uppaal.gui.Main.a(Unknown Source)
        at cs.run(Unknown Source)
        at java.awt.event.InvocationEvent.dispatch(InvocationEvent.java:209)
        at java.awt.EventQueue.dispatchEvent(EventQueue.java:598)
        at java.awt.EventDispatchThread.pumpOneEventForFilters(EventDispatchThread.java:273)
        at java.awt.EventDispatchThread.pumpEventsForFilter(EventDispatchThread.java:183)
        at java.awt.EventDispatchThread.pumpEventsForHierarchy(EventDispatchThread.java:173)
        at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:168)
        at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:160)
        at java.awt.EventDispatchThread.run(EventDispatchThread.java:121)


I would expect that original Uppaal would ignore (and remove) the additional labels and work as usual, or at least not to throw exceptions and refuse to save.
Anyway, I think there could be more such problems in the future so I'm attaching a sample document to reproduce the problem.
Comment 1 Marius Mikučionis 2006-11-16 16:56:13 CET
Created attachment 126 [details]
Uppaal-TK created model specification
Comment 2 Gerd Behrmann 2006-11-16 17:46:27 CET
Agreed. However I relabel the bug as "enhancement", since technically it is not an error not to be able to read "broken" files.
Comment 3 Gerd Behrmann 2006-12-27 21:40:55 CET
Fixed on the 4.0 branch from rev. 2885.
Comment 4 Gerd Behrmann 2006-12-27 21:46:19 CET
Fixed on the trunk from rev. 2886.