Bug 409 - View->Variables... does not remember deselected variables
Summary: View->Variables... does not remember deselected variables
Status: ASSIGNED
Alias: None
Product: UPPAAL
Classification: Unclassified
Component: GUI (show other bugs)
Version: 4.0.5
Hardware: Macintosh Mac OS
: P2 minor
Assignee: Gerd Behrmann
URL:
Depends on:
Blocks:
 
Reported: 2007-03-28 13:07 CEST by Christiaan Ottow
Modified: 2007-05-15 23:24 CEST (History)
0 users

See Also:
Architecture:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Christiaan Ottow 2007-03-28 13:07:43 CEST
On Mac OS X, the bug below still exists. In short: when in simulation you select the variables to view, this selection is not remembered between simulations. So when fixing a bug and returning to the simulation, you'll have to re-select the few out of many variables you want to see.

+++ This bug was initially created as a clone of Bug #69 +++

Unlike the View->Processes... menu item that remember which processes has been
deselected, the View->Variables... does not.

Example:
You are simulating a system with lots of variables. You decide to deselect half
of them. If afterwards want to deselect a single extra variable, you have to
again deselect all the variables you deselected the first time.
Comment 1 Gerd Behrmann 2007-05-13 18:03:20 CEST
I just checked under Linux. At least with fischer_symmetry.xml, it doesn't work either. Will investigate further.
Comment 2 Gerd Behrmann 2007-05-15 22:54:06 CEST
Fixed in the 4.0 branch from rev. 3064.

Clarification to original bug report: This bug is not the same as bug 69. Bug 69 was about the dialog box not recovering the previous selection. Bug 409 is about the selection not surviving a reload of the model into the simulator.