Bug 50 - Focus changes when zooming in close.
Summary: Focus changes when zooming in close.
Status: RESOLVED FIXED
Alias: None
Product: UPPAAL
Classification: Unclassified
Component: GUI (show other bugs)
Version: 3.5.7
Hardware: All All
: P5 minor
Assignee: Robert Olesen
URL:
Depends on:
Blocks:
 
Reported: 2003-09-10 20:05 CEST by Ulrik Nyman
Modified: 2006-02-27 18:28 CET (History)
1 user (show)

See Also:
Architecture:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Ulrik Nyman 2003-09-10 20:05:58 CEST
When zooming in so close that the whole model cannot fit inside the editing
window, the effect of zooming in closer is, both that the model becomes larger
but also that the window scrolls up and to the left. Similarly the effect of
zooming out again is both that the model becomes smaller but also that the
content is scrolled down and to the right.
Comment 1 Gerd Behrmann 2005-06-29 21:19:14 CEST
Moved bug to 3.5.7, as fixing a minor bug in a stable release series is not worth the risk.
Comment 2 Gerd Behrmann 2005-08-06 09:45:29 CEST
Mads, can you take a look at this problem.

The intended behaviour is that the center should stay in the center.
Comment 3 Mads Schaarup Andersen 2005-08-09 14:46:01 CEST
A fix has been checked into CVS.
Comment 4 Mads Schaarup Andersen 2005-08-09 16:09:31 CEST
The fix caused scrollbars to disfunction.
Comment 5 Mads Schaarup Andersen 2005-09-28 14:09:14 CEST
Reassigned to robert
Comment 6 Robert Olesen 2006-01-31 13:31:04 CET
The bug has been fixed. See SVN revision 1479.
Comment 7 Gerd Behrmann 2006-02-27 18:28:17 CET
Further improvements checked in at rev. 1567.