Bug 83 - GUI triggers an exception on syntax check (model attached)
Summary: GUI triggers an exception on syntax check (model attached)
Status: CLOSED FIXED
Alias: None
Product: UPPAAL
Classification: Unclassified
Component: GUI (show other bugs)
Version: 3.4.3
Hardware: All All
: P2 normal
Assignee: Gerd Behrmann
URL:
Depends on:
Blocks:
 
Reported: 2004-01-19 02:25 CET by Juhan Ernits
Modified: 2004-06-11 09:51 CEST (History)
0 users

See Also:
Architecture:


Attachments
A simple model illustrating the crash (808 bytes, application/octet-stream)
2004-01-19 02:27 CET, Juhan Ernits
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Juhan Ernits 2004-01-19 02:25:09 CET
Uppaal GUI triggers the following exception when template P is opened and syntax
check is triggered (this is done on opening the model). The problem was observed
under Windows and Linux.

"java.lang.IllegalArgumentException: Zero length iterator passed to TextLayout
constructor."

The problem is triggered, when the syntax checker wants to underline an 
assignment containing an error in the case, when there are empty lines
separating assignments on one transition.
Comment 1 Juhan Ernits 2004-01-19 02:27:02 CET
Created attachment 14 [details]
A simple model  illustrating the crash
Comment 2 Juhan Ernits 2004-01-19 02:56:50 CET
Changed platform to all.
Comment 3 Gerd Behrmann 2004-01-29 12:00:39 CET
A fix has been checked into CVS.