Bug 172

Summary: Invalid initial states are not handeled gracefully
Product: UPPAAL Reporter: Gerd Behrmann <behrmann>
Component: GUIAssignee: Gerd Behrmann <behrmann>
Status: RESOLVED FIXED    
Severity: normal    
Priority: P1    
Version: 3.5.7   
Hardware: All   
OS: All   
Architecture:

Description Gerd Behrmann 2005-07-05 21:25:56 CEST
If the initial state is not well defined, e.g. due to bad invariants or bad variable initialisers, then the GUI 
looses the server connection.

The expected behaviour is that such errors are shown in the editor, although this is difficult as the errors 
might only be present in some instances of a template.
Comment 1 Gerd Behrmann 2005-07-05 21:26:44 CEST
Oops, wrong assignee.
Comment 2 Gerd Behrmann 2006-02-20 19:50:06 CET
Support for this has now been added on the trunk. Out of range initialisers and
similar problems are reported like any other parse error. Ill-defined states due
to the invariants of the initial state being false are reported, but the error
is not attributed to any particular invariant: In the general case, the error
can be caused by a combination of invariants.