Bug 253

Summary: Syntax errors in invariant cause crash
Product: UPPAAL Reporter: Rena <ranab>
Component: libutapAssignee: Gerd Behrmann <behrmann>
Status: RESOLVED FIXED    
Severity: normal    
Priority: P1    
Version: 3.6 Alpha 4   
Hardware: All   
OS: All   
Architecture:

Description Rena 2006-01-31 22:31:44 CET
When you put the condition if as invariant, "server" application throw the
exception, while Uppaal has to report syntax/semantical problem.
Comment 1 Gerd Behrmann 2006-02-01 09:37:50 CET
Any keyword in an invariant seem to cause a server crash. This is most likely a problem in libutap.
Comment 2 Gerd Behrmann 2006-02-05 19:24:08 CET
Fixed on the trunk. The problem was caused by any kind of syntax error (but not
type error) in an invariant when reading an XML file (the GUI uploads the model
as an XML file).