Bug 85

Summary: server dies with "CAUGHT EXCEPTION: Invalid variable type" message
Product: UPPAAL Reporter: Juhan Ernits <juhan>
Component: EngineAssignee: Gerd Behrmann <behrmann>
Status: CLOSED FIXED    
Severity: normal    
Priority: P2    
Version: 3.4.3   
Hardware: All   
OS: All   
Architecture:
Attachments: model for reproducing the error

Description Juhan Ernits 2004-01-19 17:37:58 CET
This problem seems to be caused by the query parser.

The error message can be reproduced by the following procedure:
(open the attached project "test.xml". Notice, that there is an intentional
syntax error (space between "E" and "<>") in the query):

1. Load project test.xml;

2. Go to query tab and press "Model check". Then the error message "E: Unknown
identifier" appears (if one presses "Model check" again (not necessary for
reproducing the error) without changing anything, one is prompted with "syntax
error, unexpected T_GT" message);

3. Change the state space representation to "Options"->"State space
representation"->"Under approximation";

4. Press "Model check". Then error "CAUGHT EXCEPTION: Invalid variable type" is
prompted. It does not matter if the syntax of the query has been corrected or
not. If "Model check" is pressed again, "Fatal error: Broken pipe
The server connection has been killed." error message is prompted.
Comment 1 Juhan Ernits 2004-01-19 17:38:47 CET
Created attachment 16 [details]
model for reproducing the error
Comment 2 Gerd Behrmann 2004-01-29 13:56:37 CET
This was actually caused by the fix for bug 58. The implicit declaration of the
unknown variable 'E' would modify the model, thus causing a crash when the model
is instantiated. A fix has been checked into CVS.