Bug 495 - Java UI client not responds to keyboard every few minutes since starup
Summary: Java UI client not responds to keyboard every few minutes since starup
Status: RESOLVED INVALID
Alias: None
Product: UPPAAL CORA
Classification: Unclassified
Component: Verification Engine (show other bugs)
Version: unspecified
Hardware: PC Linux
: P2 trivial
Assignee: Marius Mikučionis
URL:
Depends on:
Blocks:
 
Reported: 2010-08-06 04:05 CEST by Patrick Pan
Modified: 2019-10-31 16:44 CET (History)
1 user (show)

See Also:
Architecture:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Patrick Pan 2010-08-06 04:05:10 CEST
############################################################################
The following legitimate information is from the version used by me:       #
############################################################################


UPPAAL 4.0.11 (rev. 4492), February 2010 Academic and non-commercial use only


###################################################
The following information is about my JRE:        #
###################################################

java version "1.6.0_20"
Java(TM) SE Runtime Environment (build 1.6.0_20-b02)
Java HotSpot(TM) Client VM (build 16.3-b01, mixed mode, sharing)

##################
The PROBLEM is:  #
##################
Not so long after startup,the UI does not respond to keyboard.For example,when I want declare a global clock variable in "Project --> Declarations " and hit the keyboard,the UI stay still as if I'm not editing.

################################################################################
Forgive my poor English for which the problem above may not be described neatly.And,by the way,another thing I want to affirm myself for is whether UPPAAL is an open-source software since I am now delving into the Model Checking algorithms and want to learn more about the implementation details.Thanks very much for your time reading my mail and replies would be welcomed.
                                                 Yours truly,
                                                 Patrick Pan
Comment 1 Marius Mikučionis 2019-10-21 10:18:22 CEST
taking over
Comment 2 Marius Mikučionis 2019-10-31 16:44:10 CET
I could not reproduce it, perhaps it has been solved in newer version.
We are using Java8 now.
Feel free to reopen if the issue persists.