Bug 135 - Engine crash during syntax check
Summary: Engine crash during syntax check
Status: CLOSED FIXED
Alias: None
Product: UPPAAL
Classification: Unclassified
Component: Engine (show other bugs)
Version: 3.4.7
Hardware: PC All
: P2 major
Assignee: Gerd Behrmann
URL: http://www.cs.aau.dk/~ulrikl/uppaal/s...
Depends on:
Blocks:
 
Reported: 2005-03-15 10:07 CET by Ulrik Nyman
Modified: 2005-06-29 21:27 CEST (History)
0 users

See Also:
Architecture:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Ulrik Nyman 2005-03-15 10:07:22 CET
If anaything that triggers an error message in a guard is followed by a comma
then the server connection is lost during the syntax check.
Comment 1 Gerd Behrmann 2005-03-21 12:57:31 CET
Confirmed.
Comment 2 Gerd Behrmann 2005-03-30 17:31:44 CEST
This was caused by a simple bug in a recovery rule in the parser. A fix for 3.4
and 3.5 has been checked into CVS.