Bug 147 - IllegalArgumentException when changing wrong sync
Summary: IllegalArgumentException when changing wrong sync
Status: RESOLVED FIXED
Alias: None
Product: UPPAAL
Classification: Unclassified
Component: GUI (show other bugs)
Version: 3.5.5
Hardware: PC Linux
: P2 minor
Assignee: Gerd Behrmann
URL:
Depends on:
Blocks:
 
Reported: 2005-04-15 09:44 CEST by Lars T. Mikkelsen
Modified: 2005-06-03 22:22 CEST (History)
0 users

See Also:
Architecture:


Attachments
Uppaal model (1.31 KB, text/plain)
2005-04-15 09:45 CEST, Lars T. Mikkelsen
Details
Stacktrace (4.43 KB, text/plain)
2005-04-15 09:46 CEST, Lars T. Mikkelsen
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Lars T. Mikkelsen 2005-04-15 09:44:59 CEST
Steps to reproduce:
1. In the attached model, change the sync "call?" to "call?[newline]c?"
2. Press F7 (Uppaal marks "c?" as a syntax error)
3. Change the sync back to "call?"

Result:
Uppaal throws an IllegalArgumentException.
Comment 1 Lars T. Mikkelsen 2005-04-15 09:45:37 CEST
Created attachment 29 [details]
Uppaal model
Comment 2 Lars T. Mikkelsen 2005-04-15 09:46:27 CEST
Created attachment 30 [details]
Stacktrace
Comment 3 Gerd Behrmann 2005-04-24 20:09:49 CEST
Can you reproduce this error? I have tried to follow your instructions, but I do
not see any exceptions at all (using Linux and UPPAAL 3.5.5).
Comment 4 Lars T. Mikkelsen 2005-04-24 23:31:37 CEST
Yes, the bug is reproducible. However, it only occurs if the sync is changed via
"Edit Edge" and not when changed via "Edit Synchronisation" - I'm sorry I didn't
make that clear in the original report.
Comment 5 Gerd Behrmann 2005-05-03 09:20:11 CEST
Yes, now I can also reproduce the error.
Comment 6 Gerd Behrmann 2005-05-03 13:39:50 CEST
I will fix the bug.
Comment 7 Gerd Behrmann 2005-06-03 22:22:42 CEST
A fix has been checked into CVS. The problem was that the edit edge dialog did not erase the previous 
error messages from the list (but the edit synchronisation dialog did).