Bug 152 - Huge templates cause crash
Summary: Huge templates cause crash
Status: RESOLVED FIXED
Alias: None
Product: UPPAAL
Classification: Unclassified
Component: Engine (show other bugs)
Version: 3.4.9
Hardware: PC All
: P2 normal
Assignee: Gerd Behrmann
URL:
Depends on:
Blocks:
 
Reported: 2005-05-10 22:47 CEST by Piotr Kordy
Modified: 2005-06-03 20:34 CEST (History)
0 users

See Also:
Architecture:


Attachments
Specification causing problems (333.29 KB, text/xml)
2005-05-10 22:48 CEST, Piotr Kordy
Details
Specification not working on linux (726.21 KB, text/xml)
2005-05-11 15:51 CEST, Piotr Kordy
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Piotr Kordy 2005-05-10 22:47:26 CEST
When trying to open the specification with 1000 locations (in attachment), the
window message appears: "Fatal error: Server connection lost The server
connection has been killed." Most probably the reason is some kind of buffer
overflow, as reducing number of locations eliminates the problem.
Comment 1 Piotr Kordy 2005-05-10 22:48:55 CEST
Created attachment 34 [details]
Specification causing problems
Comment 2 Robert Olesen 2005-05-10 23:14:11 CEST
reassigning
Comment 3 Gerd Behrmann 2005-05-11 11:45:48 CEST
Which OS do you use? I opened the model with 3.4.9 on my Mac and do not get a crash.
Comment 4 Piotr Kordy 2005-05-11 12:29:50 CEST
I used Windows XP and Linux with kernel 2.6 (marge machine) The message under
Linux is "Could not connect to server"
Comment 5 Gerd Behrmann 2005-05-11 12:49:49 CEST
I tried it on marge using version 3.4.9. Still no crash. Any further information you can give me?
Comment 6 Piotr Kordy 2005-05-11 13:25:18 CEST
I also used version 3.4.9 of Uppaal. The error does not occur immediately. The
model is shown in Uppaal but when I try to click somewhere Uppaal does not
react. It takes around 7s to show model and around 20s to show message that
connection to server was lost. (on marge) When TRON is supplied with the same
specification it ends with segmentation fault (uses 3.4.7 engine though). The
core file indicates: "Process::buildProcess (this=0x8272608) at proc.cc:196" as
the line where it fails.
Comment 7 Piotr Kordy 2005-05-11 15:51:34 CEST
Created attachment 35 [details]
Specification not working on linux
Comment 8 Piotr Kordy 2005-05-11 15:55:56 CEST
The first specification does not work on Windows only. I submitted one that
fails on linux. It has 3500 locations. Up to 3000 locations seems to work under
linux. (before I got connection lost under Linux because of not having
executable bit on executable - my fault)
Comment 9 Gerd Behrmann 2005-05-11 16:03:55 CEST
Confirmed. Thanks for the new model.
Comment 10 Gerd Behrmann 2005-06-03 14:16:53 CEST
Loading the model with verifyta causes a segfault. The problem also exists in 3.5.6.
Comment 11 Gerd Behrmann 2005-06-03 20:34:05 CEST
A fix for 3.5.x has been checked in. Since I do not consider this a serious bug, I do not plan to fix it in 3.4.