Bug 421 - Error on channel identifiers
Summary: Error on channel identifiers
Status: RESOLVED FIXED
Alias: None
Product: UPPAAL
Classification: Unclassified
Component: GUI (show other bugs)
Version: 4.0.6
Hardware: PC Linux
: P2 normal
Assignee: Alexandre David
URL:
: 450 (view as bug list)
Depends on:
Blocks:
 
Reported: 2007-05-24 14:44 CEST by Ludovic Apvrille
Modified: 2008-10-29 11:24 CET (History)
1 user (show)

See Also:
Architecture:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Ludovic Apvrille 2007-05-24 14:44:57 CEST
When two channel identifiers have the beginning of their identifier which is equal, and that beginning is equal or greater than 63 characters, this results in a "Duplicate definition" error at syntax checking.

For example, if you open a brand new UPPAAL modeling, put the following lines in the declaration section, you obtain a "duplicate definition" error.

urgent chan ttttttttttttttttttttttttttttttttttttttttttttttttttttttttttttttt1;
urgent chan ttttttttttttttttttttttttttttttttttttttttttttttttttttttttttttttt2;

I've seen no such restrictions mentioned in the grammar, but I may have missed that information.
By the way, I found this bug because I have written a UML-to-UPPAAL automatic code generator which may generate long channel names.
Comment 1 Alexandre David 2008-06-12 17:56:34 CEST
Fixed in revision 3780 in both 4.0 and trunk.
Comment 2 Alexandre David 2008-10-29 11:24:14 CET
*** Bug 450 has been marked as a duplicate of this bug. ***