Bug 476 - mac version of uppaal does not start
Summary: mac version of uppaal does not start
Status: RESOLVED DUPLICATE of bug 475
Alias: None
Product: UPPAAL
Classification: Unclassified
Component: GUI (show other bugs)
Version: 4.0.8
Hardware: Macintosh Mac OS
: P2 normal
Assignee: Alexandre David
URL:
Depends on:
Blocks:
 
Reported: 2009-06-29 14:01 CEST by Axel Belinfante
Modified: 2009-08-07 12:47 CEST (History)
0 users

See Also:
Architecture:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Axel Belinfante 2009-06-29 14:01:11 CEST
the current version of uppaal seems to require jdk 1.6?

when trying Uppaal on a mac, I get the following exception:

[JavaAppLauncher Error] CallStaticVoidMethod() threw an exception
Exception in thread "main" java.lang.NoClassDefFoundError: javax/xml/stream/XMLResolver
        at java.lang.Class.forName0(Native Method)
        at java.lang.Class.forName(Class.java:242)
        at apple.launcher.LaunchRunner.loadMainMethod(LaunchRunner.java:55)
        at apple.launcher.LaunchRunner.run(LaunchRunner.java:111)
        at apple.launcher.LaunchRunner.callMain(LaunchRunner.java:50)
        at apple.launcher.JavaApplicationLauncher.launch(JavaApplicationLauncher.java:52)

after editing.app/Contents/Info.plist to change
the value for the JVMVersion key  from1.5+  to 1.6 it works.

               <key>JVMVersion</key>
                <string>1.6</string>
Comment 1 Alexandre David 2009-08-07 12:43:24 CEST
The Mac distributions have been repackaged using a newer Mac template.
Re-download.
Comment 2 Alexandre David 2009-08-07 12:47:43 CEST

*** This bug has been marked as a duplicate of bug 475 ***