Bug 58 - connection lost to server after model load
Summary: connection lost to server after model load
Status: CLOSED FIXED
Alias: None
Product: UPPAAL
Classification: Unclassified
Component: GUI (show other bugs)
Version: 3.4.0
Hardware: All All
: P2 major
Assignee: Gerd Behrmann
URL:
: 61 (view as bug list)
Depends on:
Blocks:
 
Reported: 2003-09-16 10:55 CEST by Arne Skou
Modified: 2003-09-22 16:32 CEST (History)
1 user (show)

See Also:
Architecture:


Attachments
The Uppaal model which causes the error (18.52 KB, application/octet-stream)
2003-09-16 10:58 CEST, Arne Skou
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Arne Skou 2003-09-16 10:55:32 CEST
When loading a particular model, The GUI reports 'Fatal error. Server connection
lost The server connection has been killed'
Comment 1 Arne Skou 2003-09-16 10:58:34 CEST
Created attachment 4 [details]
The Uppaal model which causes the error
Comment 2 Gerd Behrmann 2003-09-17 15:36:04 CEST
A fix has been checked into CVS. The problem was in the error recovery for
undeclared identifiers. 

In the testcase, the process instatiation section referred to an undeclared
identifier. In order to recover from this problem (i.e. continue parsing the
rest of the document), this resulted in an expression object, which referred to
a "NULL" symbol. The type checker would then crash when finding this NULL
symbol. The solution is to implicitly declare the missing identifier as a VOID
type (after producing an error message).
Comment 3 Gerd Behrmann 2003-09-17 15:40:41 CEST
*** Bug 61 has been marked as a duplicate of this bug. ***