Bug 590 - Runtime Error
Summary: Runtime Error
Status: ASSIGNED
Alias: None
Product: UPPAAL
Classification: Unclassified
Component: Engine (show other bugs)
Version: 4.0.14
Hardware: PC Windows 8
: P5 enhancement
Assignee: Marius Mikučionis
URL:
Depends on:
Blocks:
 
Reported: 2015-01-04 13:45 CET by a95419515
Modified: 2015-12-16 11:40 CET (History)
3 users (show)

See Also:
Architecture: x86_64 (64bit)


Attachments
The error message (10.00 KB, image/png)
2015-12-16 09:57 CET, Mikael Sjödin
Details
Uppaal 4.0.14 server dependencies on healthy Windows 8.1 64bit (187.97 KB, image/png)
2015-12-16 11:33 CET, Marius Mikučionis
Details

Note You need to log in before you can comment on or make changes to this bug.
Description a95419515 2015-01-04 13:45:52 CET
When I run Uppaal I get:
"
runtime error 

program : .../bin-win32\server.exe

this application has requested the runtime to terminate it in an unusual way
"

So I can't analyse my models
Comment 1 Marius Mikučionis 2015-01-05 10:36:26 CET
I have Windows 8.1 64bit and I cannot reproduce this problem neither with version 4.0.14 nor 4.1.19. I can also run the server.exe by double-clicking it.

I need more details, like the precise version and architecture of your operating system.

Could you check the permissions and security settings of the server.exe?
I am just guessing, normally this is not needed.
Comment 2 Milan 2015-07-03 11:20:35 CEST
Hello,

I have the same problem and my OS is Windows 8.1 64bit (I have the administrator privileges). 
I only face this problem with 4.0.14 (also can't start server.exe by double-clicking it). Version 4.1.19 is working just fine.
Comment 3 Marius Mikučionis 2015-07-20 14:16:15 CEST
Thanks for the feedback. 
Could you please post a screenshot of the error?
Perhaps the error popup contains more (expandable) details?
I still cannot reproduce the problem and the error message is just too generic (it may range anywhere from device drivers, system libraries to malware corruption).
Comment 4 Mikael Sjödin 2015-12-16 09:57:51 CET
Created attachment 285 [details]
The error message
Comment 5 Mikael Sjödin 2015-12-16 10:00:47 CET
The same problem occurs for me with Windows 10. I've tried running server.exe with various compatibility-settings for Windows 7 and 8 but without luck. (BTW I have Visual Studio 2015 installed which changes some system dlls i belive.)
Comment 6 Marius Mikučionis 2015-12-16 11:33:31 CET
Created attachment 286 [details]
Uppaal 4.0.14 server dependencies on healthy Windows 8.1 64bit

Uppaal 4.0.14 server dependencies on healthy Windows 8.1 64bit
Comment 7 Marius Mikučionis 2015-12-16 11:40:24 CET
Thanks Mikael for the screenshot.

I don't have Visual Studio 2015 installed, perhaps that's the interaction causing the problem.

Could you use Dependency Walker to inspect for any errors?

Use x86 (32bit) on bin-Win32\server.exe binary.

I just attached a healthy example of it and how to read it (it shows that api-ms-win-service-private-l1-1-1.dll is missing, but it does not prevent from running, i.e. it is not important).

I would be curious about version numbers of your MSVCRT.DLL file in order to reproduce your symptoms.

Perhaps a solution is to install Visual Studio redistributable (i.e. you would have multiple versions of the same library and then hopefully it would pick the right one), like suggested here:
http://answers.microsoft.com/en-us/windows/forum/windows8_1-performance/32-bit-application-fails-to-start-after-81-upgrade/b825723e-e2a2-4c8f-bd1f-10446a5d7059