Bug 178 - Synchronising on broadcast channel blocks
Summary: Synchronising on broadcast channel blocks
Status: RESOLVED FIXED
Alias: None
Product: UPPAAL
Classification: Unclassified
Component: Engine (show other bugs)
Version: 3.5.8
Hardware: All All
: P3 critical
Assignee: Gerd Behrmann
URL:
Depends on:
Blocks:
 
Reported: 2005-08-03 11:28 CEST by René Gøttler
Modified: 2006-01-17 16:39 CET (History)
0 users

See Also:
Architecture:


Attachments
Model illustrating the problem (1.38 KB, text/xml)
2005-08-03 11:29 CEST, René Gøttler
Details

Note You need to log in before you can comment on or make changes to this bug.
Description René Gøttler 2005-08-03 11:28:50 CEST
Sending on a broadcast channel blocks a template if no enabled transitions can 
receive on that channel. This behaviour is in violation to the semantics the 
channel type as specified in the help file. Previous versions of verifyta 
(confirmed on ver. 3.5.7, WindowsXP) does not experience this.
Comment 1 René Gøttler 2005-08-03 11:29:55 CEST
Created attachment 52 [details]
Model illustrating the problem
Comment 2 Gerd Behrmann 2005-08-04 13:49:47 CEST
Confirmed. Seems to be introduced by the fix for bug 170.
Comment 3 Gerd Behrmann 2005-08-05 20:25:24 CEST
A fix is in CVS now.
Comment 4 Gerd Behrmann 2005-08-05 20:54:39 CEST
A minor remark: The CVS changelog for 3.4 contains a reference to bug 178. This should have been a 
reference to bug 177.
Comment 5 Gerd Behrmann 2006-01-17 16:38:50 CET
This bug reappeared in 3.6 alpha 3.
Comment 6 Gerd Behrmann 2006-01-17 16:39:29 CET
Fixed on the trunk (rev. 1457).